Jump to content
Nugget Shooter Forums

Night Hunt with the X-Terra 705


Recommended Posts

Since it is over 105 degrees during the day here in the Mojave, I decided to go do a night hunt with my new X-Terra 705. I say new because it has only been used for approximately half a work day since I bought it 2 months ago. It started out really well. We got to our spot and unloaded the 705, our digger, and the DetectorPro Pinpointer. I was really excited about using the pinpointer in the field because this is the first time it would have been used in the field since I bought it from Rob back at the beginning of April. That's when it all started!

I bought 2 new 9V batteries to put into the pinpointer, so I unscrewed the battery door and the thing completely fell off in my hand. Upon examination I found that one of the little retaining tabs on the door had snapped off and would not allow the door to stay closed completely. The first time in actual use, and I couldn't even use it. Bummer!!! Good thing Dave (Highbanker58) talked me into keeping it because it would not have been good at all if someone had actually bought it and I didn't know about the door. Thank you, Dave. :thumbsupanim

So we start hunting the area and we're digging up trash galore, but having fun because it's only 78 degrees out at the time. WooHoo!! We come across a nice sounding signal so we dig it. Out pops a 1947 wheat penny. Not the gold I was after, but kinda cool all the same. About another 5 or so minutes of hunting and we hit another VERY strong signal. So I flip the 705 into coin mode and activate the pinpointer. I go over the spot twice, and the sound goes completely away. Boggled, I went back to the truck and pulled out the back-up Bullseye pinpointer and run it over the spot. I get sound! So I swing the 705 back over the spot and nothing. So I turn the backlight on and look at the screen, and as I swing it over the spot I can see the numbers changing, etc. I go through the settings and make sure that everything is correct (which it was because I changed nothing) and tried it again. Still nothing. There's obviously something wrong so I just pack up and come home. I go to the garage and pull the batteries from the 705 and test them (Energizer Alkalines) and they test fine. So I put them back into the unit, turn it on, and test the unit. This time I can hear VERY LITTLE sound coming from the speaker IF I put it right next to my ear. So I grab my headphones, plug them in, turn the unit back on, drop a silver dollar on the floor, and swing over it. My eyes crossed and my ears started ringing. WAY LOUD!!! :head:

So, in a nutshell...my brand new $200 pinpointer broke before I could ever even use it and my 705 no longer has sound from the external speaker after only 5-7 hours of use (most of which was with the headphones attached). In the famous words of Frankie Valli, "Oh, what a night"! I tell ya, if it wasn't for bad luck I would have no luck at all. Both units were bought on April 8th of this year so they are still under warranty, but what a bummer that I have to send them in already. I wanted to try to get a little more familiar with the 705 because I just met a group of guys yesterday who coin hunt all over Southern California and they asked me today to join them on a hunt this coming week. Abort Operation Coin Hunt :cry2:!!!

But hey.................I still got my very first wheat penny with a detector. I am now a teenie-weenie bit closer to becoming a millionaire! :hahaha:

Link to comment
Share on other sites

I have the exact same problem with my xterra705 while on external speaker and like yours every now and then it comes back to full volume so i just use the headphones and forget about it.

Mines about 9 months old and i know if i send it in for repairs it will probably not do it in minelabs shop. But overall i really like the unit but if i was ever to trying to sell it that glitch would be a problem.

Joe

Link to comment
Share on other sites

go this off the other message board maybe this will fix it

It IS because you're over the target.

It responds just like holding your ProPointer on a target when powering up. It basiclly de-sensitizes it to that target.

Best consistant results that I get are when I'm off target, but still reading the TID that I'm pursuing when I hit the pinpoint button. It's sometimes difficult when in a peticularly trashy area.

I do notice that it effectively "blanks" the target if I'm on it when I switch to that mode, but there are also times when a halo around a rusty piece will give a good tone just off an edge, and when I change modes there's nothing there in that TID range. Then I'll swing back further than I was getting the tone and engage the iron.

Link to comment
Share on other sites

I left az for pa and all it does is RAIN ..... I want to come home but will be here for at least another two months helping out.

As for the 705 ...... I was not using the pinpoint at all and simply turning it on just gives a very faint sound on the external speaker with volume fully up..... Headphones its fine and i cant send it in for repairs on count of my traveling so will just have to wait...... Still really like this machine for coins etc.

Joe

Link to comment
Share on other sites

Thanks for the replies guys. I called Minelab Service today and spoke with Brian. This seems to be a speaker issue that Minelab has been dealing with for a bit. Brian told me that he has repaired numerous 705's with the same problem. He emailed me over a shipping label and I will send it out to be fixed first thing tomorrow. Minelab taking care of business as usual! :D

Link to comment
Share on other sites

Chris..... Thats good news. Did you call minelabs main headquarters?___________

What is the length of warranty?___________

Wish i was in one place long enough to do the same. Guess I'll have to wait til mid August but good to know they recognize the problem.

Joe

Link to comment
Share on other sites

Joe,

All new Minelab units come with a 3 year warranty. At least that's what I was told. I called the Service Department in IL and they were very helpful. Hope this helps.

Chris

Link to comment
Share on other sites

It does help a lot as i just purchased mine last november so i have lots of time.

Thanks for the info.

Joe

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...