Jump to content
Nugget Shooter Forums

No Biggy just something that messes with ya.


Recommended Posts

  • 3 weeks later...

I get it sometimes too. And sometimes I can't even get this site to come up. Seems like this started when the new server started. It feeds no data to my connection and then the internet explorer says something like can't show this web page. Weird.

Link to comment
Share on other sites

I use firefox , it's free and much faster than Internet Explorer ... and never a problem. IE was giving me problems with pages not loading or timing out so i switched. Google chrome is also fast , free , and better than IE. Just my 2 coppers , and keep the change.

Link to comment
Share on other sites

I use firefox , it's free and much faster than Internet Explorer ... and never a problem. IE was giving me problems with pages not loading or timing out so i switched. Google chrome is also fast , free , and better than IE. Just my 2 coppers , and keep the change.

Ore,

I tried those a while back plus Opera but ran into problems on the DPS web site and was then informed only IE works for their forms. So I switched back.

Man it sounds like you are adapting quite nicely to Arizona bro. Have you got use to the heat yet? lol!

Rim

Link to comment
Share on other sites

Rim,

I run and use Google Chrome mostly but I have IE8 as well on my computer if I need it, Chrome works better on all the websites and forums I visit, if I ever have a problem with Chrome on any website I can always open IE8 at that time, I also have several other browsers on my computer as well, but I have never had any issues with Chrome, I just when to Texas DPS website and was able to access all the forums I clicked on and all of them seem to only require Adobe Reader to open and use the PDF forms and didn't seem to have any issues, what was it that you experienced with the forms?

Skip

Link to comment
Share on other sites

Skip,

I did a change of address for my drivers and cc license's and found parts of the form was missing. If I remember correctly there was a section pertaining to citizenship missing when I ran into the problem. So I called them and they told me their site in Texas is set up for IE. But it's been about a year ago since I did this and maybe things have changed now. Not sure. I'm pretty sure I was using chrome because I didn't much like opera or firefox.

Rim

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...